gentoo-overlay/app-containers/podman-compose/podman-compose-1.0.6.ebuild
Gered b5401c31a2 add app-containers/podman-compose ebuilds
for the latest two versions available. 1.0.6 seems to be very new
compared to the next recent 1.0.3 which was the latest version for a
long time, so it felt like a good idea to have both available just
in case

also i still feel like i have very little idea what i'm doing with
ebuild writing, and even less so with python stuff. this is all feeling
like a lot of "magic" to me. hopefully this isn't written in a
horribly broken or bad way ...
2023-07-12 12:27:53 -04:00

26 lines
515 B
Bash

# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1 pypi
DESCRIPTION="A script to run docker-compose.yml using podman"
HOMEPAGE="https://github.com/containers/podman-compose"
KEYWORDS="~amd64 ~x86"
LICENSE="GPL-2"
SLOT="0"
DEPEND=""
RDEPEND="
${DEPEND}
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/python-dotenv[${PYTHON_USEDEP}]
"
BDEPEND=""