initial commit

This commit is contained in:
Gered 2023-03-21 15:52:55 -04:00
commit 8757d61be8
17 changed files with 338 additions and 0 deletions

5
README.md Normal file
View file

@ -0,0 +1,5 @@
# Gered's Gentoo Overlay
This is my Gentoo overlay, just for my own personal use.
You probably don't want to use this. I reserve the right to break things randomly.

View file

@ -0,0 +1,4 @@
AUX system-nlohmann_json.patch 1410 BLAKE2B a4497c5242edeb1fb6342f24739d1b6a7e6dc229bb630da7788556f54179ce4746fe2c7528375764d914ed8cf7a3b700f17e1a7a4a4fda95ab36ec6e492067d6 SHA512 0274a3602a48c0e9a70812966e08efbc15317f73f0a1ea3105c8093ff35fe35ad817e0af923350b4aac8a75b8b38ac4b43d6029ff8e7ad0c6184265f72bad608
DIST nlohmann_json-3.7.3.zip 280969 BLAKE2B 4c092314466a52b9970a24945982ed790248b85ca787ce986c1851a23bdeafb0903dc63fff9c691d9a0ad472712386adc0cb0ddf468cca3dedf0032506d0e592 SHA512 8efd82a54472335e548d0d5c375b6f2781b4a0f2dbc5aa0acc3f504277ec455e0782046286cf08eb4864ac8bcaa1a9691af8d0259dd71a9e539cfc12e0478eb5
EBUILD mcpelauncher-linux-9999.ebuild 1658 BLAKE2B d29c984a952632dfdbe61d8ad0662b54d2af1c0c15c7ab1881402ee7d51a6378717a7d97222bc89b693b2c78a8e978f1b995a1eef752e6dc9e5e9137c45be710 SHA512 6ce299b11fd846800b938a925af242815649edf7a19c6736d986de7890b8396ab6440916c78f877576ea18b324adaeaea51336789562e990e853dea5ef4f7590
MISC metadata.xml 423 BLAKE2B 6d3250882cfb4a9f05cb5f505e049a714189ae4fd4a96bdb5c5068d565c78e5786aa5fd69690d07c2d1ebfea91ee441b0037f8d0f791a2c73a416b38c15b3d83 SHA512 74efde2dbd62b1d27f9d5eaf5e3210961e837e152c1682e7fc5f8c4e02350c532c41587b18a20fdeccd30d74be98206180f99b38c3b7099daf5dae8c5f87bd2c

View file

@ -0,0 +1,39 @@
diff --git a/ext/json.cmake b/ext/json.cmake
index 9824519..35fa61f 100644
--- a/ext/json.cmake
+++ b/ext/json.cmake
@@ -1,15 +1,20 @@
-include(FetchContent)
+if(USE_EXTERNAL_JSON)
+ add_library(nlohmann_json INTERFACE IMPORTED)
+ Set_property(TARGET nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES "${JSON_SOURCES}/include")
+else()
+ include(FetchContent)
+
+ FetchContent_Declare(
+ nlohmann_json_ext
+ URL "https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip"
+ )
+
+ FetchContent_GetProperties(nlohmann_json_ext)
+ if(NOT nlohmann_json_ext_POPULATED)
+ FetchContent_Populate(nlohmann_json_ext)
+ endif()
-FetchContent_Declare(
- nlohmann_json_ext
- URL "https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip"
-)
-
-FetchContent_GetProperties(nlohmann_json_ext)
-if(NOT nlohmann_json_ext_POPULATED)
- FetchContent_Populate(nlohmann_json_ext)
+ Add_library(nlohmann_json INTERFACE IMPORTED)
+ Add_dependencies(nlohmann_json nlohmann_json_ext)
+ Set_property(TARGET nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES "${nlohmann_json_ext_SOURCE_DIR}/include")
endif()
-
-add_library(nlohmann_json INTERFACE IMPORTED)
-add_dependencies(nlohmann_json nlohmann_json_ext)
-set_property(TARGET nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES "${nlohmann_json_ext_SOURCE_DIR}/include")
\ No newline at end of file

View file

@ -0,0 +1,66 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit git-r3 cmake toolchain-funcs flag-o-matic
DESCRIPTION="Minecraft Bedrock Launcher for Linux (unofficial)"
HOMEPAGE="https://github.com/minecraft-linux/mcpelauncher-manifest"
SRC_URI="https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip -> nlohmann_json-3.7.3.zip"
EGIT_BRANCH="ng"
EGIT_REPO_URI="https://github.com/minecraft-linux/mcpelauncher-manifest.git"
LICENSE="MIT GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="+ui +msa"
DEPEND="
net-misc/curl
sys-libs/zlib
media-libs/libpng
dev-libs/libevdev
x11-libs/libXi
dev-qt/qtwebengine:5
sys-devel/clang:*
sys-devel/llvm:*"
RDEPEND="${DEPEND}
msa? ( games-util/mcpelauncher-msa-client )
ui? ( games-util/mcpelauncher-ui-qt )"
BDEPEND=""
# Prevent downloading nlohmann_json sources
PATCHES="${FILESDIR}/system-nlohmann_json.patch"
src_unpack() {
unpack "${DISTDIR}/nlohmann_json-3.7.3.zip"
git-r3_src_unpack
}
src_configure() {
# Force clang (pulled from www-client/firefox)
# Some of the code comes from Android which doesn't like GCC
elog "Forcing clang"
AR=llvm-ar
CC=${CHOST}-clang
CXX=${CHOST}-clang++
NM=llvm-nm
RANLIB=llvm-ranlib
strip-unsupported-flags
# Ensure we use correct toolchain
export HOST_CC="$(tc-getBUILD_CC)"
export HOST_CXX="$(tc-getBUILD_CXX)"
tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
local mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
-DUSE_EXTERNAL_JSON=YES # Workaround for nlohmann_json
-DJSON_SOURCES="${WORKDIR}" # Workaround for nlohmann_json
-DJNI_USE_JNIVM=ON
)
cmake_src_configure
}

View file

@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>james@thegreatmcpain.xyz</email>
<name>TheGreatMcPain</name>
</maintainer>
<use>
<flag name="msa">Install <pkg>games-util/mcpelauncher-msa-client</pkg></flag>
<flag name="ui">Install <pkg>games-util/mcpelauncher-ui-qt</pkg></flag>
</use>
</pkgmetadata>

View file

@ -0,0 +1,4 @@
AUX system-nlohmann_json.patch 1410 BLAKE2B a4497c5242edeb1fb6342f24739d1b6a7e6dc229bb630da7788556f54179ce4746fe2c7528375764d914ed8cf7a3b700f17e1a7a4a4fda95ab36ec6e492067d6 SHA512 0274a3602a48c0e9a70812966e08efbc15317f73f0a1ea3105c8093ff35fe35ad817e0af923350b4aac8a75b8b38ac4b43d6029ff8e7ad0c6184265f72bad608
DIST nlohmann_json-3.7.3.zip 280969 BLAKE2B 4c092314466a52b9970a24945982ed790248b85ca787ce986c1851a23bdeafb0903dc63fff9c691d9a0ad472712386adc0cb0ddf468cca3dedf0032506d0e592 SHA512 8efd82a54472335e548d0d5c375b6f2781b4a0f2dbc5aa0acc3f504277ec455e0782046286cf08eb4864ac8bcaa1a9691af8d0259dd71a9e539cfc12e0478eb5
EBUILD mcpelauncher-msa-client-9999.ebuild 1043 BLAKE2B 4580e389f38341a9742a90a0927d65b3a9b525f26c13b582ad50079212fb03c53116dc2a02d8b2404c395352c59749e40165f9b7719772da45b046807d904ac9 SHA512 77936a9bc88364fe4218499ccd4a67ab8c912552710b1b41eb7359d27c9889b186ec40cb2f1a9e9ead1503b310f1f91dfe2f58efc2c4802bafe4e567c0847b74
MISC metadata.xml 311 BLAKE2B 7f125ca8384bf56b3d424502a151e84d1024d5e0cb8890dde2aaa19ee5be3b9e0125f87f9828bfb11f8c57ff6fcdf4710cfc6eccd6a0a29200e03fc534aa0ac4 SHA512 3145062e154a5bc47cec269945fc3d49ea05bbeab83c571e617343dc9bf521326ef1cb892890e416820ef21e692902a1c51de00331379b1580400b5b265c3f04

View file

@ -0,0 +1,39 @@
diff --git a/ext/json.cmake b/ext/json.cmake
index 9824519..35fa61f 100644
--- a/ext/json.cmake
+++ b/ext/json.cmake
@@ -1,15 +1,20 @@
-include(FetchContent)
+if(USE_EXTERNAL_JSON)
+ add_library(nlohmann_json INTERFACE IMPORTED)
+ Set_property(TARGET nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES "${JSON_SOURCES}/include")
+else()
+ include(FetchContent)
+
+ FetchContent_Declare(
+ nlohmann_json_ext
+ URL "https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip"
+ )
+
+ FetchContent_GetProperties(nlohmann_json_ext)
+ if(NOT nlohmann_json_ext_POPULATED)
+ FetchContent_Populate(nlohmann_json_ext)
+ endif()
-FetchContent_Declare(
- nlohmann_json_ext
- URL "https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip"
-)
-
-FetchContent_GetProperties(nlohmann_json_ext)
-if(NOT nlohmann_json_ext_POPULATED)
- FetchContent_Populate(nlohmann_json_ext)
+ Add_library(nlohmann_json INTERFACE IMPORTED)
+ Add_dependencies(nlohmann_json nlohmann_json_ext)
+ Set_property(TARGET nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES "${nlohmann_json_ext_SOURCE_DIR}/include")
endif()
-
-add_library(nlohmann_json INTERFACE IMPORTED)
-add_dependencies(nlohmann_json nlohmann_json_ext)
-set_property(TARGET nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES "${nlohmann_json_ext_SOURCE_DIR}/include")
\ No newline at end of file

View file

@ -0,0 +1,42 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit git-r3 cmake
DESCRIPTION="Microsoft Account authentication daemon for mcpelauncher"
HOMEPAGE="https://github.com/minecraft-linux/msa-manifest"
SRC_URI="https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip -> nlohmann_json-3.7.3.zip"
EGIT_REPO_URI="https://github.com/minecraft-linux/msa-manifest.git"
LICENSE="MIT GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="+qt5"
DEPEND="net-misc/curl
dev-libs/openssl
dev-cpp/nlohmann_json
qt5? ( dev-qt/qtwebengine:5 )"
RDEPEND="${DEPEND}"
BDEPEND=""
# Prevent downloading nlohmann_json sources
PATCHES="${FILESDIR}/system-nlohmann_json.patch"
src_unpack() {
unpack "${DISTDIR}/nlohmann_json-3.7.3.zip"
git-r3_src_unpack
}
src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
-DUSE_EXTERNAL_JSON=YES # Workaround for nlohmann_json
-DJSON_SOURCES="${WORKDIR}" # Workaround for nlohmann_json
-DENABLE_MSA_QT_UI=$(usex qt5 ON OFF)
)
cmake_src_configure
}

View file

@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>james@thegreatmcpain.xyz</email>
<name>TheGreatMcPain</name>
</maintainer>
<use>
<flag name="qt5">"Enable QT GUI"</flag>
</use>
</pkgmetadata>

View file

@ -0,0 +1,2 @@
EBUILD mcpelauncher-ui-qt-9999.ebuild 717 BLAKE2B 56476c09c3b1f56694ee3ffb13d0cfb0ee61e69d83e6632bf41f00a555073700366a1c98f6fc170edc2384a6361bf76f74f0b438ac28bbc23446183cffc42b8e SHA512 cf0f25d861151b65f9bfea9502ad8716d0595a6a53797d86a0938cfdfe17c86cf4ef0cf780caeeb2bd0438b1f2b5275a103d4c34d3a4a9772146d43c2bef3ba3
MISC metadata.xml 254 BLAKE2B b29784dda645fac45b9c94f74b562df65c32ed7fe390e1b0a1f6f9021a32de7cfc80bac9b0af653e1cf7907a1eabe2e8e3bc923e1a374bae41d1bc71bbab1a40 SHA512 e6a56381b90d0e89195d5054f5a730f71b49d70b2166e92011b33408386438c53b0af5a95169c7c44b440cb12e3b725f4667afa62af3f02fee2e268e807e4770

View file

@ -0,0 +1,37 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit git-r3 cmake flag-o-matic
DESCRIPTION="mcpelauncher-linux UI"
HOMEPAGE="https://github.com/minecraft-linux/mcpelauncher-ui-manifest"
EGIT_BRANCH="ng"
EGIT_REPO_URI="https://github.com/minecraft-linux/mcpelauncher-ui-manifest.git"
LICENSE="MIT GPL-3"
SLOT="0"
KEYWORDS=""
DEPEND="
dev-qt/qtwebengine:5
dev-qt/qtdeclarative:5
dev-qt/qtquickcontrols:5
dev-qt/qtquickcontrols2:5
dev-qt/qtsvg:5
dev-libs/libzip
dev-libs/protobuf"
RDEPEND="${DEPEND}"
BDEPEND=""
src_configure() {
# Doesn't like LTO
filter-flags -flto*
local mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
)
cmake_src_configure
}

View file

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>james@thegreatmcpain.xyz</email>
<name>TheGreatMcPain</name>
</maintainer>
</pkgmetadata>

View file

@ -0,0 +1 @@
DIST grafx2-2.8.3091-HEAD-src.tgz 1127842 BLAKE2B df3c99e5a3d3e0f62584643f9cb92049c3b260ac50d6d9c78572781aecd89d73a017127810876133b8ffa5be732539041d0afbbc93525535e4f5e377c7efaac4 SHA512 251e3a178379691ecfbbc740fae462d5f9ea8363c923ef4b904ce791041308ebc82022dc74a5d74228391df4b9ed4c8de4498caad65a60b309d229a6552d5156

View file

@ -0,0 +1,11 @@
--- a/misc/unix/grafx2.desktop 2020-12-13 14:03:40.000000000 -0500
+++ b/misc/unix/grafx2.desktop 2023-03-21 13:47:09.666745426 -0400
@@ -2,7 +2,7 @@
Name=GrafX2
Comment=Deluxe Paint Clone
Comment[fr]=Clone de Deluxe Paint
-Exec=grafx2 %f
+Exec=grafx2-sdl2 %f
Terminal=false
Type=Application
Icon=grafx2

View file

@ -0,0 +1,53 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit xdg
DESCRIPTION="A pixelart-oriented painting program"
HOMEPAGE="http://www.pulkomandy.tk/projects/GrafX2"
SRC_URI="http://www.pulkomandy.tk/projects/GrafX2/downloads/${P}-HEAD-src.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ttf lua"
# Test phase fails: make: *** [Makefile:1146: ../bin/tests-sdl] Error 1
RESTRICT="test"
PATCHES=(
"${FILESDIR}/${PN}-desktop-file.patch"
)
DEPEND="
media-libs/libsdl2
media-libs/sdl2-image[tiff]
media-libs/freetype
media-libs/libpng
ttf? ( media-libs/sdl2-ttf )
lua? ( >=dev-lang/lua-5.1.0 )
"
S="${WORKDIR}/${PN}/src/"
src_prepare() {
pushd ../
eapply ${PATCHES}
eapply_user
popd
sed -i s/lua5\.1/lua/g Makefile || die
}
src_compile() {
use ttf || MYCNF="NOTTF=1"
use lua || MYCNF="${MYCNF} NOLUA=1"
MYCNF="${MYCNF} API=sdl2"
emake ${MYCNF} || die "emake failed"
}
src_install() {
emake ${MYCNF} DESTDIR="${D}" PREFIX="/usr" install || die "Install failed"
}

3
metadata/layout.conf Normal file
View file

@ -0,0 +1,3 @@
masters = gentoo
thin-manifests = true
sign-manifests = false

1
profiles/repo_name Normal file
View file

@ -0,0 +1 @@
gered