diff --git a/games-action/mcpelauncher-linux/mcpelauncher-linux-20230823.ebuild b/games-action/mcpelauncher-linux/mcpelauncher-linux-20230823.ebuild
deleted file mode 100644
index 5cd4407..0000000
--- a/games-action/mcpelauncher-linux/mcpelauncher-linux-20230823.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit git-r3 cmake toolchain-funcs flag-o-matic
-
-DESCRIPTION="Minecraft Bedrock Launcher for Linux (unofficial)"
-HOMEPAGE="https://github.com/minecraft-linux/mcpelauncher-manifest"
-SRC_URI="https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip -> nlohmann_json-3.7.3.zip"
-EGIT_BRANCH="ng"
-EGIT_COMMIT="1ab07f68acd8dc89af40fe1064f90210c8a4f67c"
-EGIT_REPO_URI="https://github.com/minecraft-linux/mcpelauncher-manifest.git"
-
-LICENSE="MIT GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE="+ui +msa"
-
-DEPEND="
- net-misc/curl
- sys-libs/zlib
- media-libs/libpng
- dev-libs/libevdev
- x11-libs/libXi
- dev-qt/qtwebengine:5
- llvm-core/clang:*
- llvm-core/llvm:*"
-RDEPEND="${DEPEND}
- msa? ( games-util/mcpelauncher-msa-client )
- ui? ( games-util/mcpelauncher-ui-qt )"
-BDEPEND=""
-
-# Prevent downloading nlohmann_json sources
-PATCHES="${FILESDIR}/system-nlohmann_json.patch"
-
-src_unpack() {
- unpack "${DISTDIR}/nlohmann_json-3.7.3.zip"
- git-r3_src_unpack
-}
-
-src_configure() {
- # Force clang (pulled from www-client/firefox)
- # Some of the code comes from Android which doesn't like GCC
- elog "Forcing clang"
- AR=llvm-ar
- CC=${CHOST}-clang
- CXX=${CHOST}-clang++
- NM=llvm-nm
- RANLIB=llvm-ranlib
-
- strip-unsupported-flags
-
- # Ensure we use correct toolchain
- export HOST_CC="$(tc-getBUILD_CC)"
- export HOST_CXX="$(tc-getBUILD_CXX)"
- tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
-
- local mycmakeargs=(
- -DUSE_OWN_CURL=OFF # own curl builds broken due to wrong url currently. skip it!
- -DBUILD_SHARED_LIBS=OFF
- -DUSE_EXTERNAL_JSON=YES # Workaround for nlohmann_json
- -DJSON_SOURCES="${WORKDIR}" # Workaround for nlohmann_json
- -DJNI_USE_JNIVM=ON
- )
-
- cmake_src_configure
-}
diff --git a/games-action/mcpelauncher-linux/mcpelauncher-linux-20240629.ebuild b/games-action/mcpelauncher-linux/mcpelauncher-linux-20240629.ebuild
deleted file mode 100644
index 10d1ac7..0000000
--- a/games-action/mcpelauncher-linux/mcpelauncher-linux-20240629.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit git-r3 cmake toolchain-funcs flag-o-matic
-
-DESCRIPTION="Minecraft Bedrock Launcher for Linux (unofficial)"
-HOMEPAGE="https://github.com/minecraft-linux/mcpelauncher-manifest"
-SRC_URI="https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip -> nlohmann_json-3.7.3.zip"
-EGIT_BRANCH="ng"
-EGIT_COMMIT="fa59d0acdff0bcaa4c5e40f6361125cc6d5aead3"
-EGIT_REPO_URI="https://github.com/minecraft-linux/mcpelauncher-manifest.git"
-
-LICENSE="MIT GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE="+ui +msa"
-
-DEPEND="
- net-misc/curl
- sys-libs/zlib
- media-libs/libpng
- dev-libs/libevdev
- x11-libs/libXi
- dev-qt/qtwebengine:5
- llvm-core/clang:*
- llvm-core/llvm:*"
-RDEPEND="${DEPEND}
- msa? ( games-util/mcpelauncher-msa-client )
- ui? ( games-util/mcpelauncher-ui-qt )"
-BDEPEND=""
-
-# Prevent downloading nlohmann_json sources
-PATCHES="${FILESDIR}/system-nlohmann_json.patch"
-
-src_unpack() {
- unpack "${DISTDIR}/nlohmann_json-3.7.3.zip"
- git-r3_src_unpack
-}
-
-src_configure() {
- # Force clang (pulled from www-client/firefox)
- # Some of the code comes from Android which doesn't like GCC
- elog "Forcing clang"
- AR=llvm-ar
- CC=${CHOST}-clang
- CXX=${CHOST}-clang++
- NM=llvm-nm
- RANLIB=llvm-ranlib
-
- strip-unsupported-flags
-
- # Ensure we use correct toolchain
- export HOST_CC="$(tc-getBUILD_CC)"
- export HOST_CXX="$(tc-getBUILD_CXX)"
- tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
-
- local mycmakeargs=(
- -DUSE_OWN_CURL=OFF # own curl builds broken due to wrong url currently. skip it!
- -DBUILD_SHARED_LIBS=OFF
- -DUSE_EXTERNAL_JSON=YES # Workaround for nlohmann_json
- -DJSON_SOURCES="${WORKDIR}" # Workaround for nlohmann_json
- -DJNI_USE_JNIVM=ON
- )
-
- cmake_src_configure
-}
diff --git a/games-action/mcpelauncher-linux/metadata.xml b/games-action/mcpelauncher-linux/metadata.xml
index 39146cb..bb919cf 100644
--- a/games-action/mcpelauncher-linux/metadata.xml
+++ b/games-action/mcpelauncher-linux/metadata.xml
@@ -5,8 +5,4 @@
james@thegreatmcpain.xyz
TheGreatMcPain
-
diff --git a/games-util/mcpelauncher-msa-client/Manifest b/games-util/mcpelauncher-msa-client/Manifest
deleted file mode 100644
index c0700cc..0000000
--- a/games-util/mcpelauncher-msa-client/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST nlohmann_json-3.7.3.zip 280969 BLAKE2B 4c092314466a52b9970a24945982ed790248b85ca787ce986c1851a23bdeafb0903dc63fff9c691d9a0ad472712386adc0cb0ddf468cca3dedf0032506d0e592 SHA512 8efd82a54472335e548d0d5c375b6f2781b4a0f2dbc5aa0acc3f504277ec455e0782046286cf08eb4864ac8bcaa1a9691af8d0259dd71a9e539cfc12e0478eb5
diff --git a/games-util/mcpelauncher-msa-client/files/system-nlohmann_json.patch b/games-util/mcpelauncher-msa-client/files/system-nlohmann_json.patch
deleted file mode 100644
index 4a9f516..0000000
--- a/games-util/mcpelauncher-msa-client/files/system-nlohmann_json.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/ext/json.cmake b/ext/json.cmake
-index 9824519..35fa61f 100644
---- a/ext/json.cmake
-+++ b/ext/json.cmake
-@@ -1,15 +1,20 @@
--include(FetchContent)
-+if(USE_EXTERNAL_JSON)
-+ add_library(nlohmann_json INTERFACE IMPORTED)
-+ Set_property(TARGET nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES "${JSON_SOURCES}/include")
-+else()
-+ include(FetchContent)
-+
-+ FetchContent_Declare(
-+ nlohmann_json_ext
-+ URL "https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip"
-+ )
-+
-+ FetchContent_GetProperties(nlohmann_json_ext)
-+ if(NOT nlohmann_json_ext_POPULATED)
-+ FetchContent_Populate(nlohmann_json_ext)
-+ endif()
-
--FetchContent_Declare(
-- nlohmann_json_ext
-- URL "https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip"
--)
--
--FetchContent_GetProperties(nlohmann_json_ext)
--if(NOT nlohmann_json_ext_POPULATED)
-- FetchContent_Populate(nlohmann_json_ext)
-+ Add_library(nlohmann_json INTERFACE IMPORTED)
-+ Add_dependencies(nlohmann_json nlohmann_json_ext)
-+ Set_property(TARGET nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES "${nlohmann_json_ext_SOURCE_DIR}/include")
- endif()
--
--add_library(nlohmann_json INTERFACE IMPORTED)
--add_dependencies(nlohmann_json nlohmann_json_ext)
--set_property(TARGET nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES "${nlohmann_json_ext_SOURCE_DIR}/include")
-\ No newline at end of file
diff --git a/games-util/mcpelauncher-msa-client/mcpelauncher-msa-client-20230823.ebuild b/games-util/mcpelauncher-msa-client/mcpelauncher-msa-client-20230823.ebuild
deleted file mode 100644
index 8b313aa..0000000
--- a/games-util/mcpelauncher-msa-client/mcpelauncher-msa-client-20230823.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit git-r3 cmake
-
-DESCRIPTION="Microsoft Account authentication daemon for mcpelauncher"
-HOMEPAGE="https://github.com/minecraft-linux/msa-manifest"
-SRC_URI="https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip -> nlohmann_json-3.7.3.zip"
-EGIT_BRANCH="master"
-EGIT_COMMIT="e335369d9066229bb075d4a7865424b3407934db"
-EGIT_REPO_URI="https://github.com/minecraft-linux/msa-manifest.git"
-
-LICENSE="MIT GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE="+qt5"
-
-DEPEND="net-misc/curl
- dev-libs/openssl
- dev-cpp/nlohmann_json
- qt5? ( dev-qt/qtwebengine:5 )"
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-# Prevent downloading nlohmann_json sources
-PATCHES="${FILESDIR}/system-nlohmann_json.patch"
-
-src_unpack() {
- unpack "${DISTDIR}/nlohmann_json-3.7.3.zip"
- git-r3_src_unpack
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DUSE_EXTERNAL_JSON=YES # Workaround for nlohmann_json
- -DJSON_SOURCES="${WORKDIR}" # Workaround for nlohmann_json
- -DENABLE_MSA_QT_UI=$(usex qt5 ON OFF)
- )
-
- cmake_src_configure
-}
diff --git a/games-util/mcpelauncher-msa-client/mcpelauncher-msa-client-20240629.ebuild b/games-util/mcpelauncher-msa-client/mcpelauncher-msa-client-20240629.ebuild
deleted file mode 100644
index 1c9d350..0000000
--- a/games-util/mcpelauncher-msa-client/mcpelauncher-msa-client-20240629.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit git-r3 cmake
-
-DESCRIPTION="Microsoft Account authentication daemon for mcpelauncher"
-HOMEPAGE="https://github.com/minecraft-linux/msa-manifest"
-SRC_URI="https://github.com/nlohmann/json/releases/download/v3.7.3/include.zip -> nlohmann_json-3.7.3.zip"
-EGIT_BRANCH="master"
-EGIT_COMMIT="cfcebaa0845df8e0eebaae5b211e38f8d812beab"
-EGIT_REPO_URI="https://github.com/minecraft-linux/msa-manifest.git"
-
-LICENSE="MIT GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE="+qt5"
-
-DEPEND="net-misc/curl
- dev-libs/openssl
- dev-cpp/nlohmann_json
- qt5? ( dev-qt/qtwebengine:5 )"
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-# Prevent downloading nlohmann_json sources
-PATCHES="${FILESDIR}/system-nlohmann_json.patch"
-
-src_unpack() {
- unpack "${DISTDIR}/nlohmann_json-3.7.3.zip"
- git-r3_src_unpack
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DUSE_EXTERNAL_JSON=YES # Workaround for nlohmann_json
- -DJSON_SOURCES="${WORKDIR}" # Workaround for nlohmann_json
- -DENABLE_MSA_QT_UI=$(usex qt5 ON OFF)
- )
-
- cmake_src_configure
-}
diff --git a/games-util/mcpelauncher-msa-client/metadata.xml b/games-util/mcpelauncher-msa-client/metadata.xml
deleted file mode 100644
index 1265a49..0000000
--- a/games-util/mcpelauncher-msa-client/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-
-
-
-
- james@thegreatmcpain.xyz
- TheGreatMcPain
-
-
-
diff --git a/games-util/mcpelauncher-ui-qt/mcpelauncher-ui-qt-20230823.ebuild b/games-util/mcpelauncher-ui-qt/mcpelauncher-ui-qt-20230823.ebuild
deleted file mode 100644
index 418f290..0000000
--- a/games-util/mcpelauncher-ui-qt/mcpelauncher-ui-qt-20230823.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit git-r3 cmake flag-o-matic
-
-DESCRIPTION="mcpelauncher-linux UI"
-HOMEPAGE="https://github.com/minecraft-linux/mcpelauncher-ui-manifest"
-EGIT_BRANCH="ng"
-EGIT_COMMIT="55645fedc0980b548c5b35ff62373e9b45ded557"
-EGIT_REPO_URI="https://github.com/minecraft-linux/mcpelauncher-ui-manifest.git"
-
-LICENSE="MIT GPL-3"
-SLOT="0"
-KEYWORDS=""
-
-DEPEND="
- dev-qt/qtwebengine:5
- dev-qt/qtdeclarative:5
- dev-qt/qtquickcontrols:5
- dev-qt/qtquickcontrols2:5
- dev-qt/qtsvg:5
- dev-libs/libzip
- <=dev-libs/protobuf-21.12" # 2024-06-22: temporary measure due to missing symbol issues during linking when building with newer versions
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-src_configure() {
- # Doesn't like LTO
- filter-flags -flto*
-
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DLAUNCHER_ENABLE_GLFW=OFF # 2023-08-28: just temporarily to deal with broken glfw source download during build
- )
-
- cmake_src_configure
-}
diff --git a/games-util/mcpelauncher-ui-qt/mcpelauncher-ui-qt-20240629.ebuild b/games-util/mcpelauncher-ui-qt/mcpelauncher-ui-qt-20240629.ebuild
deleted file mode 100644
index 2f24247..0000000
--- a/games-util/mcpelauncher-ui-qt/mcpelauncher-ui-qt-20240629.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit git-r3 cmake flag-o-matic
-
-DESCRIPTION="mcpelauncher-linux UI"
-HOMEPAGE="https://github.com/minecraft-linux/mcpelauncher-ui-manifest"
-EGIT_BRANCH="ng"
-EGIT_COMMIT="8eed58c4b2f4a83e7f826f0b8c85f87efe6cbc58"
-EGIT_REPO_URI="https://github.com/minecraft-linux/mcpelauncher-ui-manifest.git"
-
-LICENSE="MIT GPL-3"
-SLOT="0"
-KEYWORDS=""
-
-DEPEND="
- dev-qt/qtwebengine:5
- dev-qt/qtdeclarative:5
- dev-qt/qtquickcontrols:5
- dev-qt/qtquickcontrols2:5
- dev-qt/qtsvg:5
- dev-libs/libzip
- dev-libs/protobuf"
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-PATCHES="
- ${FILESDIR}/0001-cmake-Fix-compatibility-with-newer-protobuf-versions.patch
-"
-
-src_configure() {
- # Doesn't like LTO
- filter-flags -flto*
-
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DLAUNCHER_ENABLE_GLFW=OFF # 2023-08-28: just temporarily to deal with broken glfw source download during build
- )
-
- cmake_src_configure
-}